Significant Email Delays
Incident Report for TriumphPay
Resolved
Thank you for your patience today, this incident has been resolved and all systems are operational.
Posted Mar 01, 2022 - 16:13 EST
Update
TriumphPay Audit has cleared the backlog of emails which were enqueued and we are continuing to monitor the situation.
Posted Mar 01, 2022 - 15:51 EST
Update
TriumphPay Audit has been in communication with our email vendor and learned that email traffic was paused due to performance issues. The vendor has resumed the flow of emails and we are in the process of catching up.

While older emails are still experiencing delays due to the backlog of items which are queued to be sent, new emails should be arriving as anticipated.
Posted Mar 01, 2022 - 14:56 EST
Monitoring
TriumphPay Audit emails are beginning to catch up and we are currently monitoring.
Posted Mar 01, 2022 - 12:54 EST
Investigating
TriumphPay Audit is currently experiencing significant delays with incoming emails and we will provide additional information as it becomes available.
Posted Mar 01, 2022 - 12:41 EST
This incident affected: Email Imports.