Client Portal Uploads Outage
Incident Report for TriumphPay
Resolved
We have been informed by our provider that this issue has been resolved. Client portal uploads now work as expected.
Posted Oct 09, 2020 - 15:33 EDT
Identified
HubTran is currently experiencing loss of service in client portal uploads due to a third party outage. We recommend asking your clients to email documents directly for the time being. We will update as soon as this is resolved.
Posted Oct 09, 2020 - 13:27 EDT
This incident affected: Website.